PT-2022-4745
CVE-2022-36109
·
Published
2022-09-09
·
Updated
2026-09-18
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Moby (Docker Engine) versions prior to 20.10.18
Description
The issue is related to the improper setup of supplementary groups in Moby (Docker Engine), which can allow an attacker with direct access to a container to bypass primary group restrictions. This could potentially lead to access to sensitive information or the ability to execute code in the container. The problem can be exploited if an attacker manipulates their supplementary group access.
Recommendations
For versions prior to 20.10.18, update to Moby (Docker Engine) 20.10.18 to fix the issue.
For users unable to upgrade, do not use the "USER $USERNAME" Dockerfile instruction. Instead, call ENTRYPOINT ["su", "-", "user"] to set up supplementary groups properly.
Stop and restart running containers for the permissions to be fixed.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾