PT-2022-4784

CVE-2022-23853

·

Published

2022-02-11

·

Updated

2024-06-15

Description by

CVSS 2.0
10
High
MetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions KDE Kate versions prior to 21.12.2 KTextEditor versions prior to 5.91.0
Description The issue is related to insufficient input validation in the Language Server Protocol plugin. This can allow a remote attacker to access confidential data, compromise its integrity, and cause a denial of service. The plugin tries to execute the associated LSP server binary when opening a file of a given type. If the binary is absent from the PATH, it will attempt to run the LSP server binary in the directory of the file that was just opened, which can be an untrusted directory due to a misunderstanding of the QProcess API.
Recommendations For KDE Kate versions prior to 21.12.2, update to version 21.12.2 or later to resolve the issue. For KTextEditor versions prior to 5.91.0, update to version 5.91.0 or later to resolve the issue. As a temporary workaround, consider restricting access to untrusted directories to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2022-1325
ALT-PU-2022-1434
ALT-PU-2022-1585
ALT-PU-2022-1614
MGASA-2023-0051
OPENSUSE-SU-2022:0841-1
OPENSUSE-SU-2022_0841-1
OPENSUSE-SU-2024:11801-1
OPENSUSE-SU-2024:11813-1
SUSE-SU-2022:0841-1
SUSE-SU-2022_0841-1
Found an issue in the description? Have something to add? Feel free to write us 👾