PT-2022-4854
CVE-2022-0417
·
Published
2022-01-29
·
Updated
2026-10-23
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Vim versions prior to 8.2.
Description
The issue is related to a heap-based buffer overflow in the
ex retab function of the src/indent.c component of the Vim text editor. This occurs when using the :retab 0 command, allowing a remote attacker to access confidential data, compromise its integrity, and cause a denial of service.Recommendations
For versions prior to 8.2, update to version 8.2 or later to resolve the issue.
As a temporary workaround, consider avoiding the use of the
:retab 0 command until a patch is available.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾