PT-2022-4855

CVE-2022-0554

·

Published

2022-01-10

·

Updated

2024-06-15

Description by

CVSS 2.0
9.3
High
MetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Vim versions prior to 8.2
Description The issue is related to the enter buffer() function in the Vim text editor, which is associated with an out-of-bounds pointer offset. This allows a remote attacker to access confidential data, compromise its integrity, and cause a denial of service. The estimated number of potentially affected devices worldwide is not specified.
Recommendations For versions prior to 8.2, update to version 8.2 or later to resolve the issue. As a temporary workaround, consider restricting the use of the enter buffer() function until a patch is available.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALSA-2022:5242
ALSA-2022_5242
ALT-PU-2022-1693
ALT-PU-2022-1711
ALT-PU-2022-1731
ALT-PU-2022-1771
AZL-8565
DLA-2947-1
DLA-3182-1
MGASA-2022-0203
OESA-2022-1555
OPENSUSE-SU-2024:12337-1
RHSA-2022:5242
RHSA-2022_5242
USN-5460-1
USN-6026-1
Found an issue in the description? Have something to add? Feel free to write us 👾