PT-2022-4867
CVE-2022-3234
·
Published
2022-09-14
·
Updated
2026-10-23
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Vim versions prior to 9.0.0483
Description
The issue is related to a heap-based buffer overflow in the Vim text editor, specifically in the
utfc ptr2len() function. This can be exploited by opening a specially crafted malicious file, potentially allowing an attacker to cause a denial of service or execute arbitrary code.Recommendations
For versions prior to 9.0.0483, update to version 9.0.0483 or later to resolve the issue. As a temporary workaround, consider avoiding the use of the
utfc ptr2len() function until a patch is applied. Restrict access to untrusted files to minimize the risk of exploitation.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾