PT-2022-4976
CVE-2022-3324
·
Published
2022-09-25
·
Updated
2025-03-30
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
vim versions prior to 9.0.0598
Description
The issue is related to a stack-based buffer overflow in the vim text editor. It is associated with the
win redr ruler() function, which can cause a buffer overflow when using a negative array index with a window of negative width. This can lead to a denial of service or allow an attacker to execute arbitrary code using a specially crafted file.Recommendations
For versions prior to 9.0.0598, update to version 9.0.0598 or later to resolve the issue.
As a temporary workaround, consider restricting the use of the
win redr ruler() function until a patch is available.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾