PT-2022-4977
CVE-2022-3296
·
Published
2022-09-22
·
Updated
2026-10-16
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Vim versions prior to 9.0.0577
Description
The issue is related to a stack-based buffer overflow in the ex finally() function of the Vim text editor. Exploitation of this issue may allow an attacker to cause a denial of service or execute arbitrary code using a specially crafted file.
Recommendations
For versions prior to 9.0.0577, update to version 9.0.0577 or later to resolve the issue. As a temporary workaround, consider restricting the use of the ex finally() function until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾