PT-2022-4992
CVE-2022-3352
·
Published
2022-09-27
·
Updated
2026-10-23
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
vim versions prior to 9.0.0614
Description
The issue is related to a Use After Free vulnerability in the did set string option() function of the Vim text editor. This vulnerability can be exploited by opening a specially crafted file, potentially allowing an attacker to execute arbitrary code or cause a denial of service. The estimated number of potentially affected devices worldwide is not available.
Recommendations
For versions prior to 9.0.0614, update to version 9.0.0614 or later to resolve the issue. As a temporary workaround, consider restricting the use of the did set string option() function until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾