PT-2022-5133

CVE-2022-42010

·

Published

2022-10-05

·

Updated

2026-01-11

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:L/Au:S/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions D-Bus versions 1.12.24 and earlier, 1.13.x and earlier, 1.14.x before 1.14.4, and 1.15.x before 1.15.2
Description The issue is related to the D-Bus system's handling of type signatures, which can cause a crash when receiving a message with certain invalid signatures. An authenticated attacker can exploit this to cause dbus-daemon and other programs that use libdbus to crash. The problem is caused by a syntactically invalid type signature with incorrectly nested brackets and braces.
Recommendations For D-Bus versions 1.12.24 and earlier, update to version 1.12.24 or later. For D-Bus versions 1.13.x, update to version 1.14.4 or later. For D-Bus versions 1.14.x before 1.14.4, update to version 1.14.4 or later. For D-Bus versions 1.15.x before 1.15.2, update to version 1.15.2 or later. As a temporary workaround, consider restricting access to the dbus-daemon to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALSA-2023:0096
ALSA-2023:0335
ALT-PU-2022-3381
ALT-PU-2023-2028
ALT-PU-2024-3680
AZL-11091
CESA-2023_0096
DLA-3142-1
DSA-5250-1
MGASA-2022-0365
OESA-2022-2000
OESA-2022-2001
OESA-2022-2051
OPENSUSE-SU-2022_3805-1
OPENSUSE-SU-2022_3806-1
OPENSUSE-SU-2024:12448-1
RHSA-2022:8812
RHSA-2022:8977
RHSA-2023:0096
RHSA-2023_0096
RHSA-2023:0335
RHSA-2023_0335
RLSA-2023:0096
RLSA-2023:0335
ROSA-SA-2025-2603
SUSE-SU-2022:3804-1
SUSE-SU-2022_3804-1
SUSE-SU-2022:3805-1
SUSE-SU-2022_3805-1
SUSE-SU-2022:3806-1
SUSE-SU-2022_3806-1
SUSE-SU-2022:4295-1
SUSE-SU-2022_4295-1
USN-5704-1
Found an issue in the description? Have something to add? Feel free to write us 👾