PT-2022-5159

CVE-2022-21638

·

Published

2022-09-02

·

Updated

2024-08-30

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:L/Au:S/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions MySQL Server versions 8.0.29 and prior
Description The issue is related to insufficient input validation in the Server: Optimizer component of MySQL Server, allowing a high-privileged attacker with network access via multiple protocols to compromise the server. Successful attacks can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server.
Recommendations For versions 8.0.29 and prior, update to a version later than 8.0.29 to resolve the issue. At the moment, there is no information about additional mitigation measures for this specific vulnerability.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALSA-2022:7119
ALT-PU-2022-2552
ALT-PU-2022-3102
ALT-PU-2023-1912
ALT-PU-2023-7310
ALT-PU-2023-7463
ALT-PU-2023-7647
ALT-PU-2023-7888
AZL-11212
CESA-2022_7119
OESA-2023-1834
OESA-2023-1835
OESA-2023-1836
OESA-2024-2071
RHSA-2022:6518
RHSA-2022:6590
RHSA-2022_6590
RHSA-2022:7119
RHSA-2022_7119
RLSA-2022:6590
RLSA-2022:7119
Found an issue in the description? Have something to add? Feel free to write us 👾