PT-2022-5220
CVE-2022-2129
·
Published
2022-06-16
·
Updated
2026-10-16
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
vim versions prior to 8.2
Description
The issue is related to an out-of-bounds write in the vim regsub both function of the regexp.c component in the Vim text editor. This can allow a remote attacker to access confidential data, compromise its integrity, and cause a denial of service.
Recommendations
For versions prior to 8.2, update to version 8.2 or later to resolve the issue.
As a temporary workaround, consider restricting the use of the
vim regsub both function in the regexp.c component until a patch is available.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾