PT-2022-5929
CVE-2022-43750
·
Published
2022-09-22
·
Updated
2025-05-07
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 5.19.15
Linux kernel versions 6.x prior to 6.0.1
Description
The issue is related to a buffer overflow in the
drivers/usb/mon/mon bin.c file of the Linux kernel, which can be exploited by a user-space client to corrupt the monitor's internal memory. This could potentially allow an attacker to execute arbitrary code.Recommendations
For Linux kernel versions prior to 5.19.15, update to version 5.19.15 or later.
For Linux kernel versions 6.x prior to 6.0.1, update to version 6.0.1 or later.
As a temporary workaround, consider restricting access to the
mon bin.c module until a patch is available.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾