PT-2022-7130

CVE-2022-29217

·

Published

2022-05-12

·

Updated

2026-10-01

Description by

CVSS 2.0
7.8
High
MetricsAV:N/AC:L/Au:N/C:N/I:C/A:N
Name of the Vulnerable Software and Affected Versions PyJWT versions prior to 2.4.0
Description The issue is related to the implementation of JWT in Python PyJWT, where an attacker can exploit the lack of restrictions on certain open key formats. This allows a remote attacker to impact the integrity of data. The PyJWT library supports multiple JWT signing algorithms, and the application must specify which algorithms are supported. If the application uses jwt.algorithms.get default algorithms(), it may be vulnerable to attacks. The estimated number of potentially affected devices is not specified.
Recommendations For versions prior to 2.4.0, upgrade to v2.4.0 to receive a patch for this issue. As a temporary workaround, always be explicit with the algorithms that are accepted and expected when decoding.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-FFQJ-6FQR-9H24
AZL-9852
MGASA-2022-0244
OESA-2022-1710
OPENSUSE-SU-2022_2402-1
OPENSUSE-SU-2024:12139-1
OPENSUSE-SU-2025:14987-1
PYSEC-2022-202
SUSE-SU-2022:2401-1
SUSE-SU-2022_2401-1
SUSE-SU-2022:2402-1
SUSE-SU-2022_2402-1
SUSE-SU-2022:2403-1
SUSE-SU-2022_2403-1
SUSE-SU-2022:3545-1
SUSE-SU-2022_3545-1
SUSE-SU-2023:0794-1
SUSE-SU-2023_0794-1
USN-5526-1
USN-5526-2
Found an issue in the description? Have something to add? Feel free to write us 👾