PT-2022-7143

CVE-2022-0271

·

Published

2022-01-18

·

Updated

2022-04-15

Description by

CVSS 2.0
6.4
Medium
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:N
Name of the Vulnerable Software and Affected Versions LearnPress WordPress plugin versions prior to 4.1.6
Description The issue arises from the LearnPress WordPress plugin's failure to sanitise and escape the lp-dismiss-notice before outputting it via the lp background single email AJAX action, leading to a Reflected Cross-Site Scripting attack. This vulnerability can be exploited by a remote attacker to conduct an inter-site scripting attack.
Recommendations For versions prior to 4.1.6, update to version 4.1.6 or later to resolve the issue. As a temporary workaround, consider restricting access to the lp background single email AJAX action until a patch is applied. Avoid using the lp-dismiss-notice parameter in the affected AJAX endpoint until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾