PT-2022-7305

CVE-2021-3850

·

Published

2022-01-25

·

Updated

2024-06-10

Description by

CVSS 3.1
9.4
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions adodb versions prior to 5.20.21
Description The issue is related to an authentication bypass weakness in the adodb library. This weakness can be exploited by a remote attacker to bypass the authentication process. The vulnerability is associated with the adodb addslashes() function and can allow an attacker to inject values into a PostgreSQL connection string by providing a parameter surrounded by single quotes. Depending on how the library is used, this may allow an attacker to bypass the login process or gain access to the server's IP address.
Recommendations To resolve the issue, update to ADOdb version 5.20.21 or later. As a temporary workaround, ensure the parameters passed to ADOConnection::connect() or related functions are not surrounded by single quotes. Consider deleting line 29 in drivers/adodb-postgres64.inc.php to patch the vulnerability.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-65MJ-7C86-79JF
DLA-2912-1
DSA-5101-1
MGASA-2022-0056
USN-6825-1
Found an issue in the description? Have something to add? Feel free to write us 👾