PT-2022-7421
CVE-2022-31629
·
Published
2022-09-28
·
Updated
2025-12-27
Description by
CVSS 3.1
8.1
HighMetricsAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 7.4.31
PHP versions prior to 8.0.24
PHP versions prior to 8.1.11
Description
The issue is related to incorrect input validation in PHP, allowing network and same-site attackers to set a standard insecure cookie in the victim's browser, which is treated as a
Host- or Secure- cookie by PHP applications. This enables remote attackers to establish insecure cookies.Recommendations
For PHP versions prior to 7.4.31, update to version 7.4.31 or later.
For PHP versions prior to 8.0.24, update to version 8.0.24 or later.
For PHP versions prior to 8.1.11, update to version 8.1.11 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾