PT-2022-7565
CVE-2022-32212
·
Published
2022-07-07
·
Updated
2026-09-18
Description by
CVSS 3.1
8.1
HighMetricsAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Node.js versions prior to 14.20.0
Node.js versions prior to 16.20.0
Node.js versions prior to 18.5.0
Description
A OS Command Injection vulnerability exists in Node.js due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does not properly check if an IP address is invalid before making DBS requests, allowing rebinding attacks. The vulnerability is related to the IsIPAddress function, which lacks input validation measures. This allows a remote attacker to access confidential data, compromise its integrity, and cause a denial of service.
Recommendations
For versions prior to 14.20.0, update to version 14.20.0 or later.
For versions prior to 16.20.0, update to version 16.20.0 or later.
For versions prior to 18.5.0, update to version 18.5.0 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾