PT-2022-7576
CVE-2022-4293
·
Published
2022-10-18
·
Updated
2026-07-16
Description by
CVSS 3.1
6.8
MediumMetricsAV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Vim versions prior to 9.0.0804
Description
The issue is related to incorrect numerical computations when handling floating-point values in the
num divide function of the Vim text editor. This can allow an attacker to access confidential data and cause a denial of service. The problem is associated with a floating-point comparison using an incorrect operator.Recommendations
For versions prior to 9.0.0804, update to version 9.0.0804 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
num divide function in the eval.c file until a patch is available.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾