PT-2022-7600

CVE-2022-3520

·

Published

2022-10-14

·

Updated

2026-10-16

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Vim versions prior to 9.0.0765
Description The issue is related to a heap-based buffer overflow in the Vim text editor, specifically in the inc function. This allows an attacker to access confidential data, compromise its integrity, and cause a denial of service.
Recommendations For versions prior to 9.0.0765, update to version 9.0.0765 or later to resolve the issue. As a temporary workaround, consider restricting access to sensitive data and functions within Vim until the update can be applied.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALT-PU-2022-2980
ALT-PU-2022-3057
ALT-PU-2022-3165
ALT-PU-2022-3192
CLSA-2026-1787679179
CLSA-2026-1792153017
OESA-2022-2135
OPENSUSE-SU-2022_4631-1
SUSE-SU-2022:4631-1
SUSE-SU-2023:0209-1
USN-6420-1
Found an issue in the description? Have something to add? Feel free to write us 👾