PT-2022-8282

CVE-2019-25060

·

Published

2019-07-10

·

Updated

2022-05-17

Description by

CVSS 3.1
5.3
Medium
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions WPGraphQL WordPress plugin versions prior to 0.3.5
Description The issue allows a remote attacker to forge a GraphQL query and retrieve the account roles of every user on the site due to improper access restriction to user role information.
Recommendations For WPGraphQL WordPress plugin versions prior to 0.3.5, update to version 0.3.5 or later to resolve the issue. As a temporary workaround, consider restricting access to GraphQL queries to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-W3XG-7Q6M-3XWP
Found an issue in the description? Have something to add? Feel free to write us 👾