PT-2022-9400

CVE-2021-23470

·

Published

2022-02-04

·

Updated

2022-02-09

Description by

CVSS 3.1
8.2
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
Name of the Vulnerable Software and Affected Versions putil-merge versions prior to 3.8.0
Description The issue arises from the merge() function not checking the values passed into its argument, allowing an attacker to supply a malicious value by adjusting it to include the constructor property. This vulnerability is a result of an incomplete fix.
Recommendations For versions prior to 3.8.0, update to version 3.8.0 or later to resolve the issue. As a temporary workaround, consider disabling the merge() function until a patch is available. Restrict access to the merge() function to minimize the risk of exploitation. Avoid using the constructor property in the affected function until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-4G77-CVGW-GRVW
SNYK-JS-PUTILMERGE-2391487
Found an issue in the description? Have something to add? Feel free to write us 👾