PT-2022-9422
CVE-2021-23664
·
Published
2022-01-21
·
Updated
2022-01-28
Description by
CVSS 3.1
8.6
HighMetricsAV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions
@isomorphic-git/cors-proxy versions prior to 2.7.1
Description
The issue is related to Server-side Request Forgery (SSRF) due to missing sanitization and validation of the redirection action in middleware.js. This allows for potential exploitation.
Recommendations
For versions prior to 2.7.1, update to version 2.7.1 or later to resolve the issue. As a temporary workaround, consider disabling the redirection action in middleware.js until a patch is available. Restrict access to the middleware.js module to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾