PT-2022-9482
CVE-2021-24858
·
Published
2022-01-24
·
Updated
2022-01-27
Description by
CVSS 3.1
7.2
HighMetricsAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Cookie Notification Plugin for WordPress versions prior to 1.0.9
Description
The issue concerns an authenticated SQL Injection. It occurs because the
id GET parameter is not properly sanitised or escaped before being used in a SQL statement. This happens when retrieving settings to edit in the admin dashboard.Recommendations
For versions prior to 1.0.9, update to version 1.0.9 or later to resolve the issue. As a temporary workaround, consider restricting access to the admin dashboard to minimize the risk of exploitation. Avoid using the
id parameter in the affected endpoint until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾