PT-2022-9497

CVE-2021-24900

·

Published

2022-02-01

·

Updated

2022-03-30

Description by

CVSS 3.1
4.8
Medium
MetricsAV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Ninja Tables WordPress plugin versions prior to 4.1.8
Description The issue allows high privilege users to perform Cross-Site Scripting attacks due to the plugin not sanitising and escaping some of its table fields, even when the unfiltered html capability is disallowed.
Recommendations For versions prior to 4.1.8, update to version 4.1.8 or later to resolve the issue. As a temporary workaround, consider restricting the use of the plugin's table fields to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾