PT-2022-9556

CVE-2021-24999

·

Published

2022-01-03

·

Updated

2022-01-08

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions The Booster for WooCommerce WordPress plugin versions prior to 5.4.9
Description The issue arises from the lack of sanitization and escaping of the wcj notice parameter in the admin dashboard when the Pdf Invoicing module is enabled, leading to a Reflected Cross-Site Scripting.
Recommendations For versions prior to 5.4.9, update to version 5.4.9 or later to resolve the issue. As a temporary workaround, consider disabling the Pdf Invoicing module until a patch is available. Restrict access to the admin dashboard to minimize the risk of exploitation. Avoid using the wcj notice parameter in the affected module until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾