PT-2022-9571

CVE-2021-25014

·

Published

2022-02-14

·

Updated

2022-02-22

Description by

CVSS 3.1
3.5
Low
MetricsAV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions Ibtana WordPress plugin versions prior to 1.1.4.9
Description The issue concerns a lack of authorization and CSRF checks in the ive save general settings AJAX action. This allows any authenticated user, such as a subscriber, to call the action and change the plugin's settings, potentially leading to a Stored Cross-Site Scripting issue.
Recommendations For versions prior to 1.1.4.9, update to version 1.1.4.9 or later to resolve the issue. As a temporary workaround, consider restricting access to the ive save general settings AJAX action to prevent unauthorized changes to the plugin's settings.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾