PT-2022-9625
CVE-2021-25069
·
Published
2022-02-21
·
Updated
2022-02-28
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Download Manager WordPress plugin versions prior to 3.2.34
Description
The issue arises from the lack of sanitization and escaping of the
package ids parameter before its use in a SQL statement, leading to a SQL injection. This can also be exploited to cause a Reflected Cross-Site Scripting issue.Recommendations
For versions prior to 3.2.34, update to version 3.2.34 or later to resolve the issue. As a temporary workaround, consider restricting access to the Download Manager WordPress plugin until the update is applied. Avoid using the
package ids parameter in affected API endpoints until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾