PT-2022-9631
CVE-2021-25075
·
Published
2022-02-21
·
Updated
2022-02-28
Description by
CVSS 3.1
3.5
LowMetricsAV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Duplicate Page or Post WordPress plugin versions prior to 1.5.1
Description
The issue concerns a lack of authorization and a flawed CSRF check in the
wpdevart duplicate post parametrs save in db AJAX action. This allows any authenticated user to change the plugin's settings or perform a CSRF attack. Additionally, the lack of escaping could lead to Stored Cross-Site Scripting issues.Recommendations
For versions prior to 1.5.1, update to version 1.5.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the
wpdevart duplicate post parametrs save in db AJAX action to prevent unauthorized changes to the plugin's settings.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾