PT-2022-9658

CVE-2021-25103

·

Published

2022-02-07

·

Updated

2022-02-10

Description by

CVSS 3.1
4.7
Medium
MetricsAV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Translate WordPress with GTranslate WordPress plugin versions prior to 2.9.7
Description The issue is related to a Reflected Cross-Site Scripting problem. It occurs because the body parameter in the url addon/gtranslate-email.php file is not properly sanitized and escaped before being outputted back on the page. Exploitation of this issue requires knowledge of the NONCE SALT and NONCE KEY.
Recommendations For versions prior to 2.9.7, update to version 2.9.7 or later to resolve the issue. As a temporary workaround, consider restricting access to the url addon/gtranslate-email.php file to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾