PT-2022-9661

CVE-2021-25106

·

Published

2022-02-07

·

Updated

2022-02-11

Description by

CVSS 3.1
5.4
Medium
MetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions WPLegalPages WordPress plugin versions prior to 2.7.1
Description The issue arises from the plugin's failure to check for authorization and its flawed CSRF logic when saving settings, allowing any authenticated user to update them. Additionally, the lack of sanitization and escaping can lead to Stored Cross-Site Scripting.
Recommendations For versions prior to 2.7.1, update to version 2.7.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the plugin's settings page to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾