PT-2022-9663
CVE-2021-25108
·
Published
2022-02-07
·
Updated
2022-02-25
Description by
CVSS 3.1
7.1
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H
Name of the Vulnerable Software and Affected Versions
IP2Location Country Blocker WordPress plugin versions prior to 2.26.6
Description
The issue concerns a lack of CSRF check in the
ip2location country blocker save rules AJAX action. This allows attackers to make a logged-in admin block arbitrary countries or all of them at once, preventing users from accessing the frontend.Recommendations
For versions prior to 2.26.6, update to version 2.26.6 or later to resolve the issue. As a temporary workaround, consider restricting access to the
ip2location country blocker save rules AJAX action to minimize the risk of exploitation.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾