PT-2023-11373

CVE-2019-25146

·

Published

2023-06-07

·

Updated

2023-06-13

Description by

CVSS 3.1
7.2
High
MetricsAV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions DELUCKS SEO plugin for WordPress versions up to, and including, 2.1.7
Description The issue is related to Stored Cross-Site Scripting, which occurs due to insufficient input sanitization and output escaping in the saveSettings() function. This allows unauthenticated attackers to inject arbitrary web scripts in pages, which execute whenever a victim accesses the page.
Recommendations For versions up to, and including, 2.1.7, consider disabling the saveSettings() function until a patch is available to prevent exploitation. Restrict access to the plugin's settings page to minimize the risk of unauthorized script injection. Update to a version later than 2.1.7 when available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾