PT-2023-12438

CVE-2021-4335

·

Published

2023-10-19

·

Updated

2023-10-26

Description by

CVSS 3.1
6.3
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions The Fancy Product Designer plugin for WordPress versions up to, and including, 4.6.9
Description The issue allows unauthorized access to data and modification of plugin settings due to a missing capability check on multiple AJAX functions. This makes it possible for authenticated attackers with subscriber-level permissions to modify plugin settings, including retrieving arbitrary order information or creating/updating/deleting products, orders, or other sensitive information not associated with their own account.
Recommendations For versions up to, and including, 4.6.9, update to a version higher than 4.6.9 to resolve the issue. As a temporary workaround, consider restricting access to the AJAX functions until a patch is available. Additionally, restrict subscriber-level permissions to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾