PT-2023-12521

CVE-2021-4409

·

Published

2023-07-12

·

Updated

2023-07-19

Description by

CVSS 3.1
4.3
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions WooCommerce Etsy Integration plugin for WordPress versions up to, and including, 3.3.1
Description The issue arises from missing or incorrect nonce validation on the etcpf delete feed() function, allowing unauthenticated attackers to delete an export feed via a forged request if they can trick a site administrator into performing a specific action, such as clicking on a link.
Recommendations For versions up to, and including, 3.3.1, update to a version higher than 3.3.1 to resolve the issue. As a temporary workaround, consider disabling the etcpf delete feed() function until a patch is available. Restrict access to the export feed functionality to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾