PT-2023-12845
CVE-2022-25978
·
Published
2023-02-15
·
Updated
2025-03-18
Description by
CVSS 3.1
6.1
MediumMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
github.com/usememos/memos/server versions prior to 0.11.0
Description
The issue is related to Cross-site Scripting (XSS) due to insufficient checks on external resources. This allows malicious actors to introduce links starting with a
javascript: scheme, which can be used as part of an XSS attack.Recommendations
For versions prior to 0.11.0, update to version 0.11.0 or later to resolve the issue. As a temporary workaround, consider restricting the use of external resources to minimize the risk of exploitation. Avoid using links starting with the
javascript: scheme in the affected application until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾