PT-2023-14537

CVE-2022-4472

·

Published

2023-01-30

·

Updated

2025-03-28

Description by

CVSS 3.1
5.4
Medium
MetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions The Simple Sitemap WordPress plugin versions prior to 3.5.8
Description The issue arises from the plugin's failure to validate and escape some of its shortcode attributes before outputting them back in the page. This could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks, which could be used against high privilege users such as admins.
Recommendations For versions prior to 3.5.8, update to version 3.5.8 or later to resolve the issue. As a temporary workaround, consider restricting the use of shortcode attributes to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾