PT-2023-14993
CVE-2022-4671
·
Published
2023-01-30
·
Updated
2025-03-27
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
PixCodes WordPress plugin versions prior to 2.3.7
Description
The issue concerns the PixCodes WordPress plugin, which does not properly validate and escape certain shortcode attributes before outputting them. This could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks, potentially targeting high-privilege users such as admins.
Recommendations
For PixCodes WordPress plugin versions prior to 2.3.7, update to version 2.3.7 or later to resolve the issue. As a temporary workaround, consider restricting the use of the vulnerable shortcode attributes to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾