PT-2023-15348
CVE-2022-4747
·
Published
2023-02-06
·
Updated
2025-03-25
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
The Post Category Image With Grid and Slider WordPress plugin versions prior to 1.4.8
Description
The issue allows users with a role as low as contributor to perform Stored Cross-Site Scripting attacks, which could be used against high privilege users such as admins. This is due to the plugin not validating and escaping some of its shortcode attributes before outputting them back in the page.
Recommendations
For versions prior to 1.4.8, update to version 1.4.8 or later to resolve the issue. As a temporary workaround, consider restricting the use of the vulnerable shortcode attributes to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾