PT-2023-15432

CVE-2022-4761

·

Published

2023-02-21

·

Updated

2025-03-12

Description by

CVSS 3.1
6.8
Medium
MetricsAV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Post Views Count WordPress plugin versions 3.0.2 and earlier
Description The issue allows users with the contributor role and above to perform Stored Cross-Site Scripting attacks due to the plugin not validating and escaping some of its shortcode attributes before outputting them back in a page/post where the shortcode is embedded.
Recommendations For Post Views Count WordPress plugin versions 3.0.2 and earlier, update to a version later than 3.0.2 to resolve the issue. As a temporary workaround, consider restricting the use of the vulnerable shortcode attributes to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾