PT-2023-15483

CVE-2022-4777

·

Published

2023-02-21

·

Updated

2025-03-12

Description by

CVSS 3.1
5.4
Medium
MetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Bootstrap Shortcodes WordPress plugin versions 3.4.0 and earlier
Description The issue concerns the failure to validate and escape certain shortcode attributes, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks. This occurs when these attributes are outputted back in a page or post where the shortcode is embedded.
Recommendations For Bootstrap Shortcodes WordPress plugin versions 3.4.0 and earlier, update to a version later than 3.4.0 to resolve the issue. As a temporary workaround, consider restricting the use of shortcodes by users with the contributor role and above until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾