PT-2023-1582
CVE-2023-22974
·
Published
2023-02-22
·
Updated
2026-10-24
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:C/I:N/A:N
Name of the Vulnerable Software and Affected Versions
OpenEMR versions prior to 7.0.0
Description
The issue is related to a Path Traversal vulnerability in the setup.php file of OpenEMR. This vulnerability allows remote unauthenticated users to read arbitrary files by controlling a connection to an attacker-controlled MySQL server. The vulnerability is due to incorrect restriction of the directory path name with limited access. Exploitation of the vulnerability may allow a remote attacker to gain unauthorized access to protected information.
Recommendations
For OpenEMR versions prior to 7.0.0, update to version 7.0.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the setup.php file until a patch is available. Avoid using the setup.php file to connect to external MySQL servers until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾