PT-2023-15977
CVE-2023-0060
·
Published
2023-02-13
·
Updated
2025-03-21
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Responsive Gallery Grid WordPress plugin versions prior to 2.3.9
Description
The issue concerns the failure to validate and escape certain shortcode attributes, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks. This occurs when these attributes are outputted back in a page or post where the shortcode is embedded.
Recommendations
For versions prior to 2.3.9, update to version 2.3.9 or later to resolve the issue. As a temporary workaround, consider restricting the use of shortcodes by users with the contributor role and above until the update is applied.
Found an issue in the description? Have something to add? Feel free to write us 👾