PT-2023-16112
CVE-2023-0252
·
Published
2023-02-06
·
Updated
2025-03-25
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Contextual Related Posts WordPress plugin versions prior to 3.3.1
Description
The issue concerns a lack of validation and escaping of certain block options in the Contextual Related Posts WordPress plugin. This could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Recommendations
For versions prior to 3.3.1, update to version 3.3.1 or later to resolve the issue. As a temporary workaround, consider restricting the contributor role and above from accessing the block options until the update is applied.
Found an issue in the description? Have something to add? Feel free to write us 👾