PT-2023-16221
CVE-2023-0371
·
Published
2023-02-21
·
Updated
2025-03-13
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
EmbedSocial WordPress plugin versions prior to 1.1.28
Description
The issue is related to the EmbedSocial WordPress plugin, which does not validate and escape some of its shortcode attributes before outputting them back in a page or post where the shortcode is embedded. This could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Recommendations
For versions prior to 1.1.28, update to version 1.1.28 or later to resolve the issue. As a temporary workaround, consider restricting the use of shortcodes to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾