PT-2023-1695
CVE-2023-25735
·
Published
2023-02-14
·
Updated
2026-10-24
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Firefox versions prior to 110
Thunderbird versions prior to 102.8
Firefox ESR versions prior to 102.8
Description
The issue is related to cross-compartment wrappers wrapping a scripted proxy, which could cause objects from other compartments to be stored in the main compartment, resulting in a use-after-free after unwrapping the proxy. This can be exploited by a remote attacker to store objects from other compartments in the main compartment.
Recommendations
For Firefox versions prior to 110, update to version 110 or later.
For Thunderbird versions prior to 102.8, update to version 102.8 or later.
For Firefox ESR versions prior to 102.8, update to version 102.8 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾