PT-2023-18382
CVE-2023-2221
·
Published
2023-06-19
·
Updated
2024-12-12
Description by
CVSS 3.1
7.2
HighMetricsAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
WP Custom Cursors WordPress plugin versions prior to 3.2
Description
The issue arises from the plugin's failure to properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection. This can be exploited by users with a role as low as Admin.
Recommendations
For WP Custom Cursors WordPress plugin versions prior to 3.2, update to version 3.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the plugin's functionality to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾