PT-2023-18463
CVE-2023-2237
·
Published
2023-06-09
·
Updated
2023-06-15
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
WP Replicate Post plugin for WordPress versions up to, and including, 4.0.2
Description
The issue allows contributor-level attackers or higher to extract sensitive information from the database due to insufficient escaping on the user-supplied
post id parameter and lack of sufficient preparation on the existing SQL query, making it possible to append additional SQL queries into already existing queries.Recommendations
For WP Replicate Post plugin for WordPress versions up to, and including, 4.0.2, update to a version higher than 4.0.2 to resolve the issue. As a temporary workaround, consider restricting access to the
post id parameter to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾