PT-2023-18472

CVE-2023-22380

·

Published

2023-02-16

·

Updated

2025-03-19

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions GitHub Enterprise Server versions 3.7 through 3.7.5
Description A path traversal issue was identified that allows arbitrary file reading when building a GitHub Pages site. To exploit this, an attacker needs permission to create and build a GitHub Pages site on the instance. The issue was reported via the GitHub Bug Bounty program.
Recommendations For GitHub Enterprise Server versions 3.7 through 3.7.5, update to version 3.7.6 to resolve the issue. As a temporary workaround, consider restricting permissions to create and build GitHub Pages sites on the GitHub Enterprise Server instance until the update is applied.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾