PT-2023-18542

CVE-2023-22491

·

Published

2023-01-11

·

Updated

2026-09-29

Description by

CVSS 3.1
8.1
High
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions gatsby-transformer-remark versions prior to 5.25.1 and 6.3.2
Description The gatsby-transformer-remark plugin is vulnerable to JavaScript injection in its default configuration, unless input is sanitized. The vulnerability is present when passing input in data mode, querying MarkdownRemark nodes via GraphQL. Injected JavaScript executes in the context of the build server. To exploit this vulnerability, untrusted or unsanitized input would need to be sourced by or added into a file processed by gatsby-transformer-remark.
Recommendations For versions prior to 5.25.1, update to version 5.25.1 or later. For versions prior to 6.3.2, update to version 6.3.2 or later. As a temporary workaround, if an older version of gatsby-transformer-remark must be used, input passed into the plugin should be sanitized ahead of processing. It is encouraged for projects to upgrade to the latest major release branch for all Gatsby plugins to ensure the latest security updates and bug fixes are received in a timely manner.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-7CH4-RR99-CQCW
Found an issue in the description? Have something to add? Feel free to write us 👾