PT-2023-18685

CVE-2023-2277

·

Published

2023-06-13

·

Updated

2023-06-16

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions WP Directory Kit plugin for WordPress versions up to, and including, 1.1.9
Description The issue is due to missing or incorrect nonce validation on the insert function, making it possible for unauthenticated attackers to update the plugin's settings and inject malicious JavaScript via a forged request. This can happen if an attacker can trick a site administrator into performing an action such as clicking on a link.
Recommendations For WP Directory Kit plugin for WordPress versions up to, and including, 1.1.9, update to a version higher than 1.1.9 to resolve the issue. As a temporary workaround, consider disabling the insert function until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾